MacOS Monterey – Issues/Problems

MacOS Monterey 12.0 – There are some problems with getting connected. Please check out the solutions below.

MacOS Monterey 12.1 – This seems to have got better with connectivity; but every ALTERNATE connection fails. This is a weird issue, it is also frustrating that it takes 20 seconds or so before it times out. Do try it out. Hold connection will reduce the occurrence of this problem.

The original issue is only with making the first connection with KeyPad. If you had KeyPad working with the iOS device before you upgraded to MacOS Monterey it continues to work.

When I first tried it out I thought that a MacOS bug I had found in February 2020 had come back to haunt me. See my links below to blog posts that I had written at that time.

I am digging a little deeper and looks like there is more to it. Yes there is a problem. Yes it is a bug in MacOS but it looks like it can be worked around.

Update: Apple TV no longer works with MacOS Monterey. If you had set it up with Big Sur or an earlier OS it will continue to works. If you are trying to make a new connection the AppleTV will never detect the Mac with KeyPad. This is a change in MacOS Monterey.

Approach to getting it to work – tested with iPhone SE 2

Go to the Preferences screen in KeyPad,

Click “Launch Bluetooth Settings…”

Go to the iPhone Settings | Bluuetooth (wait till the MacOS computer name appears, it seems to take longer with Monterey, you could get frurstrated, click on back to settings and click bluetooth again. It now appears instantly…weird)

Click on the Computer Name

It asks you to Pair with the Mac.

When you click pair it spins for a bit and then gives an error. “Connection Unsuccessful – Make sure “device name” is turned on and in range.

Click on ok oto close the error.

Solution 1: You will see the device in the “My devices” list, and it says “Not connected” click on that item again and magically it connects. (but somethimes it does not).

Solution 2: Reboot the iphone (after trying solution 1). Go to Settings | Bluetooth and try to connect again. Sometimes it works, and sometimes it does not.

Solution 3: On the Mac go to bluetooth settings and Turn bluetooth off, and then Turn Bluetooth On again. Try to connect from the Phone again.

Solution 4: Exit KeyPad Application, launch KeyPad application again and try to connect from the iPhone.

Why so many solutions!!! Each of these solutions worked multiple times for me. I am looking for the one solution that always works. I have not found it yet. It looks like the real problem is that the bluetooth works ever ALTERNATE connection.

Please reach out to me at tools@toolbunch.com. Help me make KeyPad better. And do send a complaint to Apple. Its nuts that this keeps breaking.

https://bluetooth-keyboard.com/blog/keypad-does-not-work-with-macos-10-15-3/
https://bluetooth-keyboard.com/blog/keypad-has-stopped-working-for-ios-devices-on-mojave-and-high-sierra-too/